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Chapter 1

Introduction to the User Guide for

NCPEA Authors1

note: This module has been retired as it contained Connexions documentation which is no longer
accurate and/or relevant. Please visit the help page2 for up-to-date information about the Con-
nexions website, including support for viewing and authoring content and the CNXML language.
If you have any additional questions or cannot �nd the answer to your question, please contact
techsupport@cnx.org3 and we will be happy to assist in any way we can.

1This content is available online at <http://cnx.org/content/m13051/1.3/>.
2http://cnx.org/help
3techsupport@cnx.org
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Chapter 2

Getting a Connexions Account1

note: This module has been retired as it contained Connexions documentation which is no longer
accurate and/or relevant. The current documentation of topics in this module can be located
at http://cnx.org/content/m37412/latest/2. Please visit the help page3 for up-to-date informa-
tion about the Connexions website, including support for viewing and authoring content and the
CNXML language. If you have any additional questions or cannot �nd the answer to your question,
please contact techsupport@cnx.org4 and we will be happy to assist in any way we can.

1This content is available online at <http://cnx.org/content/m13050/1.4/>.
2"Create a Connexions Account" <http://cnx.org/content/m37412/latest/>
3http://cnx.org/help
4techsupport@cnx.org

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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Chapter 3

Setting Up a Workgroup1

note: This module has been retired as it contained Connexions documentation which is no longer
accurate and/or relevant. The current documentation of topics in this module can be located
at http://cnx.org/content/m37462/latest/2. Please visit the help page3 for up-to-date informa-
tion about the Connexions website, including support for viewing and authoring content and the
CNXML language. If you have any additional questions or cannot �nd the answer to your question,
please contact techsupport@cnx.org4 and we will be happy to assist in any way we can.

1This content is available online at <http://cnx.org/content/m13049/1.6/>.
2"Work Areas Overview" <http://cnx.org/content/m37462/latest/>
3http://cnx.org/help
4techsupport@cnx.org

Available for free at Connexions <http://cnx.org/content/col10304/1.2>

5



6 CHAPTER 3. SETTING UP A WORKGROUP

Available for free at Connexions <http://cnx.org/content/col10304/1.2>



Chapter 4

Import Microsoft Word or OpenO�ce

documents1

4.1 Overview

One of the easiest paths for populating a module is the Word/OOo importer, which converts a *.doc document
to CNXML. The importer overwrites any existing CNXML, so it is most useful as an initial import.
We suggest using the online Edit-in-Place feature to make any further edits; any re-import of a Word or
OpenO�ce document will erase any other changes you have made using Edit-in-Place or the Full Source
Editor.
Who should use the Word/OOo importer?
You should use the Word/OOo importer if you already have a Word or OpenO�ce document saved that
you wish to publish to the repository. The importer will correctly convert objects like section headings
(designated by innate Word/OOo styles like Heading 1 or Heading 2), paragraphs (separated by two line
breaks), tables, lists, images, footnotes, and even mathematical objects.

You can go one step further and apply the special CNXML styles in our template to your document
so that you are able to import CNXML-speci�c objects like examples, problems, notes, citations, quotes,
and more. The Word/OOo importer can produce most of the CNXML2 tags available for authors to use in
their modules (see What can I import? (Section 4.4: What can I import?) below) and several combinations
of tags. Any use case not available as a Word/OOo style must be added after import, either using the
Edit-in-Place interface (recommended) or full-source editing.

How does it work?

1. First you need to apply the CNXML styles from our template3 to your document. We have sections
below with speci�c instructions for both Word (Section 4.2: Preparing documents in Microsoft Word)
and OpenO�ce (Section 4.3: Preparing documents in OpenO�ce Writer).

2. Next, you need to prepare your Word or OpenO�ce document for import. The importer will ignore
any user-de�ned styling, and requires speci�c markup in order to import other objects correct. We
recommend that you read through the What can I import? (Section 4.4: What can I import?) section
to learn what can be imported and make sure that your document has been properly prepared.

3. Be sure to save with a *.doc extension (Windows 97-2003 compatible).
4. Create a new blank module in one of your Work Areas.
5. Use the importer on either the Edit or Files tab to import your saved document.

1This content is available online at <http://cnx.org/content/m13056/1.5/>.
2http://cnx.org/content/m13056/latest/../eip-help/tags
3http://cnx.org/help/authoring/templates/Connexions-Document.dot

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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4.2 Preparing documents in Microsoft Word

Download a copy of the document template (*.dot)4 .
You may also want to download a copy of a sample document (*.doc)5 that has been prepared to properly

exercise all the features of the template. We encourage you to have a look at the document and practice
uploading it (see "Uploading Your Document" (Section 4.5: Uploading your document)) to get a feel for
how the Word import process works.

4.2.1 Creating a new document with the template

To create a new document in Microsoft Word to import into Connexions, download and open either the
template6 or the sample document7 from above. In Microsoft Word go to the File menu and select Save
As. In the "Save As" dialog box that appears make sure that "Word Document (*.doc)" or "Word 97-2003
(*.doc)" appears in the Save as Type drop-down box. Give your document a unique name in the File

Name box, and click the Save button. You have now created a new Word document with the template styles
included in it. Delete the default text from the template and begin typing your document, adding styles as
you go as described below.

Alternatively, you can install the template �le into Word so that it is available through the New option
in the Word File menu. Instructions to install this template are speci�c to your version of Word, so we
recommend that you consult Word's Help feature if you wish to do so.

4.2.2 Applying Styles to an Existing Document

If you already have a document that you wish to import, you will need to apply the template styles to the
document. To apply the template to an existing document, �rst open that document in Word. Then, follow
the steps below:

1. Go to the Tools menu and click Templates and Add-Ins.
2. Click the Attach button, and use the �le browser to navigate to the folder where you saved the template

�le.
3. Select the "Connexions_Document.dot" icon in that folder and click Open.
4. In the �Templates and Add-Ins� window, make sure the �Automatically Update document styles� box

is checked and click Ok. (Figure 1 (Figure 4.1))

4http://cnx.org/help/authoring/templates/Connexions-Document.dot
5http://cnx.org/help/authoring/templates/WordExample.doc
6http://cnx.org/help/authoring/templates/Connexions-Document.dot
7http://cnx.org/help/authoring/templates/WordExample.doc

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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Figure 4.1: Microsoft Word's template add-in window.

As an alternative, you can also create a new blank document with the Word Importer template styles as
described in "Creating a New Document with the Template" (Section 4.2.1: Creating a new document with
the template). Once you have done so, you can copy and paste the text from your original document into
the new blank document as follows. Go to the Edit menu in the original Word document and select the
Select All option. Then go to the Edit menu in the original Word document again and select the Copy

option. This copies the text of the original document to your system clipboard. Next, go to the Edit menu
in the new blank Word document with the Word Importer template styles and select the Paste option. The
text of the original document is now copied into your new document, and you can begin modifying it with
Word Importer style information as described in the next section.

4.2.3 Using styles in Microsoft Word

If you are using Microsoft Word 97, you can �nd the style drop-down box on your format toolbar at the
top of the screen (it usually displays the default style Heading 1 or Normal). In newer versions of Word the
style menu is located under the "Home" tab. Click the pop-out icon in the lower right corner of the Styles
menu to see a list of all styles.

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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Figure 4.2: The Styles menu in new versions of Word.

To apply a style to a speci�c piece of text, you follow the instructions below:

1. Highlight the word, phrase, or paragraph you want to semantically mark up.
2. Locate the styles menu.
3. Click the name of the semantic style you want to apply to the highlighted text. The text that was

highlighted is automatically given the style you selected.

4.3 Preparing documents in OpenO�ce Writer

Download a copy of the document template (*.dot)8 .
You may also want to download a copy of a sample document (*.doc)9 that has been prepared to properly

exercise all the features of the template. We encourage you to have a look at the document and practice
uploading it (see "Uploading Your Document" (Section 4.5: Uploading your document) below) to get a feel
for how the Word import process works.

4.3.1 Creating a New Document with the Template

To create a new document in OpenO�ce Writer to import into Connexions, download and open either the
template10 or the sample document11 from above. In OpenO�ce Writer go to the File menu and select
Save As. In the "Save As" dialog box that appears make sure that "Word Document (*.doc)" or "Word
97-2003 (*.doc)" appears in the Save as Type drop-down box. Give your document a unique name in the
File Name box, and click the Save button. You have now created a new document with the template styles
included in it. Delete the default text from the template and begin typing your document, adding styles as
you go as described below.

4.3.2 Applying the Template to an Existing Document

To apply the template to an existing document, create a new blank document with the OpenO�ce Importer
template styles as described in "Creating a New Document with the Template" (Section 4.3.1: Creating a
New Document with the Template). Once you have done so, you can copy and paste the text from your
original document into the new blank document as follows. Go to the Edit menu in the original OpenO�ce
Writer document and select the Select All option. Then go to the Edit menu in the original OpenO�ce
Writer document again and select the Copy option. This copies the text of the original document to your
system clipboard. Next, go to the Edit menu in the new blank OpenO�ce Writer document with the

8http://cnx.org/help/authoring/templates/Connexions-Document.dot
9http://cnx.org/help/authoring/templates/WordExample.doc

10http://cnx.org/help/authoring/templates/Connexions-Document.dot
11http://cnx.org/help/authoring/templates/WordExample.doc

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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OpenO�ce Importer template styles and select the Paste option. The text of the original document is now
copied into your new document, and you can begin modifying it with OpenO�ce Importer style information
as described in the next section.

4.3.3 Using styles in OpenO�ce Writer

You can see the styles available to you with the template by going to the Format menu and selecting the
Styles and Formatting option. This brings up the "Styles and Formatting" box. Paragraph styles (such
as Heading 1, Heading 2, and CNXML Quote) are available by clicking on the leftmost icon at the top of the
box. Character styles (such as CNXML Emphasis, CNXML Code, and the rest of the application-speci�c styles)
are available by clicking on the second-leftmost icon at the top of the box .

(a) (b)

Figure 4.3: (a) Paragraph styles. (b) Character styles.

To apply a style to a speci�c piece of text, you follow the instructions below:

1. Select the appropriate style from the "Styles and Formatting" box.
2. Make sure the "Fill Format Mode" tool is selected in the "Styles and Formatting" box (appears as the

paint bucket icon in the�gure (Figure 4.3) above.
3. Highlight the text to which you wish to apply the style, and it will be applied.

4.4 What can I import?

• Text markup using the template styles (Section 4.4.1: Text markup using the template styles)
• Other objects (Section 4.4.2: Other objects)
• Caution to users of MathType 5 (Section 4.4.3: Caution to users of MathType 5)

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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• Some common mistakes (Section 4.4.4: Some common mistakes)

4.4.1 Text markup using the template styles

We can use the text styles provided by the template to generate Connexions text markup tags when the
document is imported.
Emphasis
The CNXML Emphasis style is used to give emphasis12 to important text. Use this style where you would
have used bold or italics to emphasize particular words or phrases. Note that boldface and italicized text
will both import as an emphasis tag with the appropriate e�ect attribute.
Foreign
The CNXML Foreign style allows us to designate a term which is in another language than the rest of the
text. We can also point its usage at a website of our choice by marking it as a hyperlink in addition to CNXML
Foreign. This will produce foreign13 text in a module.
Code
With the CNXML Code style, we can designate inline text as code14 written in a computer programming
language. Use CNXML Code (Block) to designate blocks of code that should be set o� from surrounding
text.
Cite
The CNXML Cite style allows us to refer to non-electronic sources. If you are using Microsoft Word to
prepare your document, you can cite a hyperlinked source by marking it as a hyperlink and then applying
CNXML Cite. This is produce a citation15 in Connexions.
Term
With the CNXML Term style, we can designate key terms16 in our document. If you are using Microsoft
Word to prepare your document, you can also point this term at an example of its usage by marking it as a
hyperlink and then applying CNXML Term.
Quote
Using the CNXML Quote (Block) style, we can designate a section of text as a block quote17 from another
source. Use CNXML Quote (Inline) to designate inline quotes that should not be set apart from the sur-
rounding text. If you are using Microsoft Word to prepare your document, you could also point this at an
online source by marking it as a hyperlink and then applying CNXML Quote (Inline).
Hyperlinks
Using the Hyperlink style, we can create a hyperlink pointing to a URL. This will become a link18 element
in your Connexions module. We can also point at speci�c locations within the document by pointing, for
example, at any section title created using the H1, H2, . . . styles, or at any bookmark we have inserted into
the document.
Exercise
We can make exercises19 that only have problems by marking them up using the CNXML Exercise (Problem)

style. We can also make exercises that have problems and solutions by following the text marked CNXML

Exercise (Problem) with some more text marked CNXML Exercise (Solution).
Theorems
We can have theorems20 with or without proofs. To make a theorem statement, we can use the CNXML

Theorem (Statement) style. To construct a theorem with both a statement and a proof, we use CNXML

12http://cnx.org/eip-help/emphasis
13http://cnx.org/eip-help/foreign
14http://cnx.org/eip-help/code
15http://cnx.org/eip-help/cite
16http://cnx.org/eip-help/term
17http://cnx.org/eip-help/quote
18http://cnx.org/eip-help/link
19http://cnx.org/eip-help/exercise
20http://cnx.org/eip-help/rule

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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Theorem (Statement) followed by CNXML Theorem (Proof).
De�nitions
We can have terms21 with de�nitions22 . To do so, we mark the term using the CNXML Definition (Term)

style, and we follow it with the explanation marked using the CNXML Definition (Meaning) style.
Notes
We can create note23 boxes using the CNXML Note style.
Examples
We can create example24 boxes using the CNXML Example style.

4.4.2 Other objects

We can do more than just mark up text using the Word/OOo importer. We can also add images to our
document, create tables, add lists, and even insert mathematical expressions. . .
Sections
H1 applied to a section title produces a new section25 . The section lasts until the next H1-marked title. An
H2-marked title in between produces a subsection (which lasts until the next H2- or H1-marked title).
Paragraphs
You can also use certain features of the Word or OpenO�ce editor to produce other CNXML tags. Pressing
Enter gives a new line and produces a new paragraph26 .
Images
You can insert images27 into your Word document as you would normally, and they will import into
Connexions. It's best to stick to image types such as with .eps, .jpg, .png, and .gif (or any format with a
valid image type28 ); avoid formats such as .wmf and .svg, and avoid Clip Art.

Use only images that are locally available on your machine. Make sure either that (1) the images are
already available under a creative commons (CC) attribution license29 , or (2) you own the image copyrights
and are willing to make them available under a CC attribution license.
Figure
We can precede images with text marked with the CNXML Figure Title style to give them a title, and
follow them with text marked in the CNXML Figure Caption style to give them a caption. This will produce
a �gure30 in the module.
Tables
Using the built-in Word table editor, we can create tables31 which are easily imported into Connexions.
Lists
We can create both bulleted and numbered lists32 using Word or OpenO�ce and bring them into Connexions
using the importer.
Mathematics
We can include mathematics in a line of text. Mathematics set o� from other text in its own paragraph will
import as an equation33 .

In OpenO�ce, choose Insert > Object from the menu and then select Formula.
In Word we can use the built-in Equation Editor 3.0. To do this, choose Insert > Object from the

menu and select Equation Editor 3.0. warning: It is very important that you insert and equation through

21http://cnx.org/eip-help/term
22http://cnx.org/eip-help/de�nition
23http://cnx.org/eip-help/note
24http://cnx.org/eip-help/example
25http://cnx.org/eip-help/section
26http://cnx.org/eip-help/para
27http://cnx.org/eip-help/image
28http://www.duke.edu/websrv/�le-extensions.html
29http://creativecommons.org/licenses/by/3.0/
30http://cnx.org/eip-help/�gure
31http://cnx.org/eip-help/table
32http://cnx.org/eip-help/list
33http://cnx.org/eip-help/equation

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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the Object menu. Newer versions of Microsoft Word have an option to insert an Equation, located under
the Symbols menu. Do not use this as it will not import correctly.

Figure 4.4: Insert equations through the Object menu.

If you can't �nd the Equation Editor 3.0 option in the list, you must install Equation 3.0 from your
Microsoft O�ce installation CD. Please consult your Microsoft O�ce help for more information on this
procedure.

warning: If you have MathType 5 installed on your system, math will not import correctly. See
below (Section 4.4.3: Caution to users of MathType 5) for how to remedy this.

Figure 4.5: Microsoft O�ce object insert window.

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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Footnotes
Footnotes inserted using the native footnote tool will import as Connexions footnotes34 .
Glossary
Finally, we can designate a glossary35 section for our module. We must �rst give it a title and mark that
with the CNXML Glossary Section style. This must be the last section designation used at the end of your
word document, and it cannot be followed by H1, H2, etc. styles. Then, for each glossary element we wish
to include, we mark the term portion with CNXML Definition (Term) and the meaning portion with CNXML

Definition (Meaning), as we did before in the body of our document.

4.4.3 Caution to users of MathType 5

MathType 5 is a stand-alone equation editing package written by Design Science, makers of the Microsoft
Equation 3.0 editor. When MathType 5 is installed on your system, equations written with the Microsoft
equation editor will be saved as MathType 5 equations rather than Equation 3.0 equations. Even merely
editing equations from a document with Equation 3.0 equations on a machine with MathType 5 will cause
those equations to be saved in MathType 5 format. This is problematic, since the Word importer cannot
properly convert MathType 5 equations to Presentation MathML.

We recommend un-installing MathType 5 from your system if it is currently installed. This will cause
Word to revert to using Equation 3.0 for equation editing, which will allow the Word importer to properly
generate mathematics.

Should you inadvertently include a MathType 5 equation in your Word document, in the Edit-in-Place
interface where the mathematics should appear you will instead see the warning message shown in Figure 5
(Figure 4.6).

Figure 4.6: Edit-in-Place warning for MathType mathematics import.

You can go replace each of these warning messages by hand using the following procedure. To begin,
double click on the MathType equation in Word to open the MathType editor.

If this is your �rst time to use this procedure, you must con�gure MathType to properly generate
MathML. Go to the Preferences menu and select the Translators option. In the window that appears,
make sure that �Translation to other language (text)� is selected, and in the drop-down box next to �Trans-
lator:�, select the �MathML 2.0 (m namespace)� option. Also, make sure that �Include translator name in
translation� and �Include MathType data in translation� are NOT selected (see Figure 6 (Figure 4.7) below).
Click OK to complete the con�guration. This sets the translation preferences permanently, so you will not
have to repeat these steps again.

34http://cnx.org/eip-help/footnote
35http://cnx.org/eip-help/glossary

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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Figure 4.7: Setting the translator in MathType to copy MathML to the system clipboard.

Once the Translators preferences are set, you can copy the MathType equation's MathML equivalent by
highlighting the equation in the MathType editor and copying to the clipboard (Edit menu, Copy option).
This stores a copy of the MathML on your system's clipboard.

Return to your browser and �nd the appropriate placeholder for the equation in the Edit-in-Place interface
(appearing as in Figure 5 (Figure 4.6)). Double click to edit the paragraph and delete the text �***SORRY,
THIS MEDIA TYPE IS NOT SUPPORTED***� (Figure Figure 7 (Figure 4.8) below). Paste the contents of
the clipboard into is place (Figure Figure 8 (Figure 4.9)), and click Save. Your equation should now appear
in the Edit-in-Place interface (Figure Figure 9 (Figure 4.10)).

Figure 4.8: Editing the paragraph with the warning text

Figure 4.9: Pasting the MathML copied from the MathType editor into the paragraph where the
equation should appear.

Figure 4.10: MathML equation appearing in the edit-in-place interface.

4.4.4 Some common mistakes

It is important that you follow the instructions on this page for each object. Do not use other objects or
text, including:

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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1. Do not add line breaks betwen paragraphs using cntl-Enter. This will not import as a new paragraph.
2. Do not use tabs. This formatting will not import.
3. Do not use lists or tables to invisibly format the document, as these constructs are literally imported

as lists and tables into CNXML.
4. Do not continue list numbering across separate lists.
5. Do not insert images whose source �les are remotely available via a hyperlink.
6. Do not use Word's image captioning option; the caption will import as a new paragraph.
7. Do not use fonts such as �Wingdings" to produce symbols: They will be interpretted as text.
8. Do not use the MathType editor inside Word to create equations. This is the default (and only) option

if MathType is installed on your system. See the Notes on Including Mathematics (Section 4.4.3:
Caution to users of MathType 5) section for more details.

4.5 Uploading your document

1. If you have not already done so, create36 a new blank module.
2. Use the help documents linked above to ensure you have prepared your document correctly; otherwise

you may get an error.
3. The importer dropdown menu is accessible on both the module Content tab and the Files tab when

editing the module. Choose the importer type from the dropdown menu and click Import

Figure 4.11: The module import menu (expanded).

4. On the next page, browse to your saved �le on your harddrive and click Import.

Figure 4.12: Browse to �le.

36http://cnx.org/help/authoring/createmodule

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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Chapter 5

Revising Your Content in Connexions1

warning: This module contains Connexions documentation which is out-of-date. The contents
of this module are provided here for historical purposes only and should not be considered
accurate for the current version of the Connexions website. The current documentation of topics
in this module can be located at http://cnx.org/content/m38193/latest/2. Please visit the help
page3 for up-to-date information about the Connexions website, including support for viewing and
authoring content and the CNXML language. If you have any additional questions or cannot �nd
the answer to your question, please contact techsupport@cnx.org4 and we will be happy to assist
in any way we can.

5.1 Options for Revising Your Connexions Content

After you have imported a Microsoft Word �le into a Connexions module, you may discover that you need
to revise the content. You have the option to make the revisions in the original Word document and then
import it again into Connexions, or you can revise the content within Connexions using the Edit-In-Place
editor. This module explains how to revise your content using the Edit-In-Place editor.

5.2 Revising with the Edit-In-Place Editor

The Edit-In-Place editor is the default editor on the "Edit" tab. You can insert new text and media objects
into a module or modify the existing contents of a module with this editor. You do not have to be familiar
with the CMXML tags to use Edit-In-Place. It inserts the appropriate CNXML tags for you when you insert
a new item in the �le. In addition, it has a help text feature that describes the CNXML tags for the items
you insert or edit with it.

5.2.1 Editing Imported Content with Edit-In-Place

To edit the content of a module that you imported from a Word document, use the following steps:

1. Log into Connexions.
2. Display the Connexions workspace or workgroup in which your document resides.
3. Display the module you want to edit with Edit-In-Place.
4. Scroll down to display the gray text box that contains the item you want to edit.

1This content is available online at <http://cnx.org/content/m13055/1.5/>.
2"Editing Module Contents" <http://cnx.org/content/m38193/latest/>
3http://cnx.org/help
4techsupport@cnx.org

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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5. Click in the text box. The gray box is replaced by a blue editing box (Figure 5.1) that displays the
text of the item.

Figure 5.1: The blue text box in the Edit-In-Place editor.

6. Make the necessary changes to the item.
7. Click Save to save the entry or click Cancel to clear the entry in the blue editing box.
8. Repeat steps 4 through 7 for any item you want to edit.

note: In the gray text boxes mathematical equations are displayed as they appear in the module.
In the blue editing box mathematical equations are displayed in the MathML markup language.
Edit equations by making changes to the MathML.

5.2.2 Adding New Content with Edit-In-Place

You can add new content items to a module with Edit-In-Place. The types of items you can add are:
paragraphs, enumerated lists, bulleted lists, equations, exercises, �gures, code blocks, notes, and examples.
Edit-In-Place places the opening and closing CNXML tags around the item and it generates a unique item
ID for each item you add. To add new items, use the following steps:

1. Log into Connexions.
2. Display the Connexions workspace or workgroup in which your document resides.
3. Display the module you want to edit with Edit-In-Place.
4. Scroll down to display the location in the module in which you want to insert the content item. You

can insert the new item above or below and existing item by using the Add Here button above or below
the existing item

5. Select the type of item you want to enter from the drop-down list next to the Add Here button. The
default is "Paragraph". These items are described in the help text, which can be accessed by selecting
"Other Elements" from the drop-down list.

6. Click Add Here. An empty blue editing box displays for the item you selected. You can display help
text for the item you selected by clicking Help editing xxx in the upper right corner of the blue box,
where xxx is the CNXML tag for the item you selected.

7. Type the text that is appropriate for the type of item in the blue editing box.
8. Click Save to save the entry or click Cancel to clear the entry in the blue editing box.
9. Repeat steps 4 through 8 for each new content item you want to add to the module.

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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5.2.3 Inserting Content in an Empty Module

To insert text and media objects into a new module that contains no content, use the following steps:

1. Log into Connexions.
2. Display the Connexions workspace or workgroup in which your document resides.
3. Display the module you want to edit with Edit-In-Place.
4. Click in the gray box (Figure 5.2) that says "Click To Insert Text" in the Edit-In-Place editor.

Figure 5.2: The "Click To Insert Text" text box in the Edit-In-Place editor.

The gray box is replaced by a blue editing box.
5. Type the text you want to add in the blue editing box (Figure 5.3) that says "Insert Module Text

Here".

Figure 5.3: The "Insert Module Text Here" editing box in the Edit-In-Place editor.

6. Click Save to save the text you typed. The blue editing box is replaced by a gray box that displays
your entry.

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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Chapter 6

Publishing Content1

To make any unpublished changes to an existing module or collection viewable by anyone on the Internet,
you must publish the content in Connexions. To publish content, use the following steps:

1. Click on the "Publish" tab. The "Publish Module" (Figure 6.1) (or "Publish Collection") screen
displays. This screen contains a list of reminders for you to check before you publish the content, as
well as a reminder of the terms of the license agreement.

2. Type a brief description of your new changes to the content in the "Description of Changes" text box.
3. Click Publish. Your changes to the content are entered into the Connexions Content Repository as

a new version of the existing content (version 1.1 if the content is being published for the �rst time).
Once in the Content Repository, anyone with Internet access can view the new version module or
collection.

1This content is available online at <http://cnx.org/content/m13054/1.3/>.

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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Figure 6.1: The "Publish" tab on a module.

Available for free at Connexions <http://cnx.org/content/col10304/1.2>
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A new module or collection would not necessarily have editing changes, so in the "Description of Changes"
text box you might enter a comment like "Created a new module" or "Created a new collection".

note: Once published, a module or collection may not be "unpublished" or removed from the Con-
tent Repository. Therefore, use the Preview2 feature to preview what the module or collection
will look like once published; only publish when you are sure you have a draft that you don't mind
making public.

2"Previewing a Module" <http://cnx.org/content/m38209/latest/>
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Chapter 7

Additional Connexions Information

Sources1

note: This module has been retired as it contained Connexions documentation which is no longer
accurate and/or relevant. Please visit the help page2 for up-to-date information about the Con-
nexions website, including support for viewing and authoring content and the CNXML language.
If you have any additional questions or cannot �nd the answer to your question, please contact
techsupport@cnx.org3 and we will be happy to assist in any way we can.

1This content is available online at <http://cnx.org/content/m13053/1.3/>.
2http://cnx.org/help
3techsupport@cnx.org
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Index of Keywords and Terms

Keywords are listed by the section with that keyword (page numbers are in parentheses). Keywords
do not necessarily appear in the text of the page. They are merely associated with that section. Ex.
apples, � 1.1 (1) Terms are referenced by the page they appear on. Ex. apples, 1

A account, � 2(3)
Author, � 1(1)

C collection, � 6(23)

D document, � 5(19)

E edit, � 5(19)
Edit-In-Place, � 5(19)

M members, � 3(5)
Microsoft, � 4(7)
module, � 6(23)

N NCPEA, � 1(1), � 3(5)

P paragraph, � 4(7)
publish, � 6(23)

R revise, � 5(19)
revision, � 5(19)

S style, � 4(7)

T template, � 4(7)

W Word, � 4(7)
work area, � 3(5)
workgroup, � 3(5)
workspace, � 3(5)
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User Guide for NCPEA Connexions Authors
Instructions for creating, editing, and publishing Connexions content for NCPEA authors.

About Connexions
Since 1999, Connexions has been pioneering a global system where anyone can create course materials and
make them fully accessible and easily reusable free of charge. We are a Web-based authoring, teaching and
learning environment open to anyone interested in education, including students, teachers, professors and
lifelong learners. We connect ideas and facilitate educational communities.

Connexions's modular, interactive courses are in use worldwide by universities, community colleges, K-12
schools, distance learners, and lifelong learners. Connexions materials are in many languages, including
English, Spanish, Chinese, Japanese, Italian, Vietnamese, French, Portuguese, and Thai. Connexions is part
of an exciting new information distribution system that allows for Print on Demand Books. Connexions
has partnered with innovative on-demand publisher QOOP to accelerate the delivery of printed course
materials and textbooks into classrooms worldwide at lower prices than traditional academic publishers.


