You are here: Home » Help » Techsupport » Browser Support

Browser Support

This page describes the current support for several popular browsers. If you are using a browser not listed below, feel free to tell us about your experiences. While we cannot provide full support to all browsers, we do try to make sure that the site works for as many people as possible.

Fully Supported Browsers

Browsers with Limited Support

Unsupported Browsers


Fully Supported Browsers

These browsers are fully supported. New site features and bug reports are tested in these browsers to ensure compatibility. Any problems viewing content using these browsers should be reported to technical support. Please note that browser version numbers other than those listed here may not be fully supported.


Firefox 3+

Firefox 3 and above is supported.

Note: If you are upgrading from Firefox 2 to the latest version of Firefox and had previously installed the fonts for Firefox 2, you will need to uninstall those fonts before attempting to use the Edit-in-Place authoring interface. One of the fonts (cmsy10.ttf) is not compatible with Firefox 3 and causes strange characters to be displayed when using Edit-in-Place wherever MathML is used. These characters only appear in the authoring interface and do not get displayed when the module is viewed online or in print. To resolve this issue, simply remove cmsy10.ttf from your system fonts. If you used our installation program to install these fonts on a Windows-based computer, you can remove them using the uninstaller program through the Add/Remove Programs control panel.

You can download a free copy of Firefox at http://www.mozilla.com/en-US/firefox/.

Last updated: 09 December 2011

Internet Explorer 7 & 8

Internet Explorer 7 and 8 are fully supported. You can download a free copy of Internet Explorer from Microsoft's website.

Last updated: 01 February 2011
Version: Internet Explorer 8

Chrome

Google Chrome is fully supported. You can download a free copy of Chrome from Google's website.

Last updated: 01 February 2011

Safari

Safari is fully supported. You can download a free copy of Safari from Apple's website. Last updated: 01 February 2011

Browsers with Limited Support

These browsers are known to work with the website, but are not necessarily tested during the development of new features. Though we do not anticipate any problems, please note that you may encounter unexpected results when using the browsers listed below. This section also includes browsers that have previously been supported, but are now considered outdated.


Internet Explorer 9

Internet Explorer 9 can be used to view content from Connexions, but there are some limitations. Dropdowns along the top of a Collection or Module do not work in Internet Explorer 9. As a workaround, use the links at the bottom of a module or collection.

Module and Collection editing also does not work in Internet Explorer 9. One of the supported browsers listed above must be used for content editing.

Last updated: 09 December 2011

Opera 10

Opera 10 introduces native support for MathML, an exciting new development that propels this browser into the ranks of partially supported browsers. Our testing so far has shown success not only with displaying MathML content accurately, but also working in the Edit-in-Place authoring environment, making it a viable candidate for authors and end-users alike.

Please note that we do not currently test new features and site updates using this browser, and are not prepared to offer full support at this time. You may receive a warning about MathML being displayed incorrectly when viewing a MathML-enabled module; while our tests have shown success with rendering MathML in the Opera browser so far, we require additional testing before we can assume that the math output is accurate in all cases.

If you experience any problems using Opera to either view or create content, please let us know.

You can download a free copy of Opera 10 from the Opera website.

Last updated: 08 October 2009
Version: Opera 10

Firefox 2

Firefox 2 is fully supported. In order to properly display MathML content, however, you will need to download a set of fonts that will allow your browser to properly display MathML content. Windows users can use our MathML font installer for Firefox 2.

You can download a free copy of Firefox 2 from the Mozilla Foundation website. Please be aware that installing older versions of the Firefox browser may expose you and your computer to known security risks as described in the link provided above.

Last updated: 08 October 2009
Version: Firefox 2

Unsupported Browsers

These browsers are not compatible and are not supported. If you currently use one of these browsers, please consider switching to one of the supported browsers listed above.


Internet Explorer 6

Internet Explorer 6 and older versions are outdated and unsupported. Please consider upgrading to a modern, fully supported browser. You can download a current version of Internet Explorer from Microsoft's website.


Netscape 7

Netscape 7 and older versions are outdated and unsupported. Please consider upgrading to a modern, fully supported browser. You can download a free copy of Firefox 3 at http://www.mozilla.com/en-US/firefox/.

My Account